Thursday, February 26, 2009

View GSHDSL Line Bandwidth

In order to view the GSHDSL line bandwidth execute " sh controllers atm(slot number) " command on Cisco Router IOS.


Read more...

Wednesday, February 25, 2009

Cisco Router & Microsoft Web Sites Access Problem

If you are using Cisco Router with ADSL WIC card and you have problem about accessing sites ex. Hotmail.com , MSN.com

The problem is the MTU setting.
Execute The Following commands to change the mtu settings on interface

ip mtu 1492
ip tcp adjust-mss 1452 //mss: max-segment-size (between 500-1460)
Read more...

View CPU Utilization with every show command

Execute "terminal exec prompt timestamp", then


Every show command displays current time and CPU utilization before the result presented.





To disable, Execute;

"term no exec prompt time"
Read more...

Cisco IOS DHCP address assignment using client device' MAC address

Assigning specified IP address to device using its Hardware Address(MAC).

ip dhcp pool ittipstricks
host 192.168.3.222 255.255.255.0
hardware-address ba0f.de83.b2a9
dns-server 192.168.3.1 192.168.3.2
Read more...

RIP Configuration on all interfaces

Assume that you have two or more interfaces connected to different networks or subnets on your router ;

Ex.

interface Serial1/1
ip address 10.0.3.5 255.255.255.255
!
interface Serial1/2
ip address 195.167.3.1 255.255.255.252
!
interface Serial1/3
ip address 178.168.2.1 255.255.255.252



You can configure RIP protocol using one network command instead of using network command for each network/subnet.

Using Network command for each subnet/network

router rip
version 2
network 10.0.0.0
network 172.16.0.0
network 192.168.1.0
no auto-summary

RIP confguration using only one network command for all interfaces.
The network configuration command accepts the default network (0.0.0.0) as its parameter, causing RIP Protocol to run on all interfaces on a router.

router rip
version 2
network 0.0.0.0 //You can use only one network command for all interfaces
no auto-summary


Read more...

Cisco Router Detailed Hardware Information

Use "show hardware" command to view detailed hardware installed on your router



Read more...

Tuesday, February 24, 2009

Routing Between VLANs on Cisco IOS





SWITCH # conf t

(config)# vlan database

(config-vlan)# vlan 10 name RED

(config-vlan)# vlan 30 name GREEN

(config-vlan)# exit(config)# interface FastEthernet1/0/1

(config-if)# description trunk-to-router

(config-if)# switchport trunk encapsulation dot1q

(config-if)# switchport mode trunk

(config-if)# exit

(config)# interface FastEthernet1/0/2

(config-if)# description connection-to-VLAN-10

(config-if)# switchport mode access

(config-if)# switchport access vlan 10

(config-if)# exit(config)# interface FastEthernet1/0/3

(config-if)# description connection-to-VLAN-30

(config-if)# switchport mode access

(config-if)# switchport access vlan 30

(config-if)# exit(config)# exit# copy run start



ROUTER# conf t

(config)# interface fastethernet 0/0.10

(config-if)# encapsulation dot1q 10

(config-if)# ip address 10.10.10.2 255.255.255.0

(config-if)# exit(config)# interface fastethernet 0/0.20

(config-if)# encapsulation dot1q 30

(config-if)# ip address 20.20.20.2 255.255.255.0
(config-if)# exit
In order for the two hosts that are in different VLANs can communicate between them, they must set as default gateway the IP address of the corresponding router subinterface address.


Read more...

Cisco IOS Port Redirection Configuration

Assume that we have an one sngle public IP address and we have Web and E-mail server that need to be accessed from this IP.

Request from Port 80 will be redirected to 10.0.0.12
Request from Port 25 will be redirected to 10.0.0.14

Configuration:
Router(config)# interface ethernet 0
Router(config-if )# ip address 10.0.0.1 255.255.255.0
Router(config-if )# ip nat inside
Router(config)# interface serial 0
Router(config-if )# ip address 85.75.95.111 255.255.255.252
Router(config-if )# ip nat outside
Router(config)# ip nat inside source static tcp 10.0.0.12 80 100.100.100.1 80
Router(config)# ip nat inside source static tcp 10.0.0.14 25 100.100.100.1 25
Read more...

Setting the Clock and Time Zone on Cisco IOS

Router#clock set 3:42:00 2 February 2009
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock timezone EST +2
Router(config)#clock summer-time EDT recurring
Read more...

Set interface Config to Factory Defaults on Cisco IOS

Erasing an Interface Config

Example


Router(config)# default interface fa0/1




Read more...

Filtering Command Output on Cisco IOS

You can filter Cisco IOS "show" commands output by using begin arguments;


Router# show run begin line con ( This command will show running config from the line that consist "con" word.



Read more...

Block Skype on Cisco IOS 12.4(4)T

NBAR configuration commands to block Skype packets

class−map match−any p2p
match protocol skype

policy−map block−p2p
class p2p
drop

int FastEthernet0
description internet interface
service−policy input block−p2p

To find out the high bandwidth consuming applications being used in your network, you can access the interface connected to the Internet and configure following command

ip nbar protocol-discovery.

This command above enable nbar discovery on your router.

Use following command:-

show ip nbar protocol-discovery stats bit-rate top-n 10

This command above show you top 10 bandwidth consuming applications being used by the users. Now you will be able to block/restrict traffic with appropriate QoS policy.

You can use ip nbar port-map command to look for the protocol or protocol name, using a port number or numbers other than the well-known ports.

Usage as per cisco:-
ip nbar port-map protocol-name [tcp udp] port-number

Up to 16 ports can be specified with this command. Port number values can range from 0 to 65535


Read more...

Friday, February 20, 2009

Client log on to which Domain Controller ?

Execute the Command Below on the command Prompt

set logonserver
Read more...

SMTP Address Variables

SMTP Address Variables that you can use in Recipient Policies




%d@domain.com ittips@domain.com
%r._%d@domain.com it_tips@domain.com
%g.%s@domain.com it.tips@domain.com
@domain.com itt@domain.com
%1g%s@domain.com itips@domain.com
%1g%3s@domain.com itip@domain.com
Read more...

Enable or Disable Firewall on Windows 2008 Core Installation.

Disable Windows Firewall

netsh firewall set opmode disable

Enable Windows Firewall

netsh firewall set opmode enable

Enable File and Print Sharing Feature

netsh firewall set service fileandprint

Open specific ports

netsh firewall set portopening protocol=TCP UDP port=portnumarası name=anyname

Allow Specific program

netsh firewall set allowedprogram program=c:\programs=anyname

Enable Ping

netsh firewall set icmpsetting 8
Read more...

Disable Shutdown Event Tracker

Shutdown Event Tracker option is coming Default with Windows XP & Windows 2003 OSs.


But in Windows XP it is disabled by default.
Messages that you type in the comment part is logged as Event ID:1076






Disable Shutdown Event Tracker.

In Domain or Local Group Policy

Locate Computer Configuration > Administrative Templates > System
In the right pane locate "Display Shutdown Event Tracker" and double click.
Choose "Disabled"
Read more...

Wednesday, February 18, 2009

(Center)Metro Ethernet - Branch Office GSHDSL Configuration Example

Branch Office GSHDSL Configuration

controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto

!!!!interface BRI0
no ip address
encapsulation hdlc
shutdown!

interface ATM0
no ip address
no atm ilmi-keepalive

!interface ATM0.1 point-to-point
description METRO ---->G.SHDSL 1024/1024
ip address 192.168.203.2 255.255.255.252
ip virtual-reassembly
atm route-bridged ip
pvc 0/35
Read more...

Reset Administrator Password on ILO

Search you server for the "hponcfg.exe" file.

Write code below to notepad and Save file as "Administrator_reset_pw.xml"


Note: //newpass is your new ILO password


Copy Administrator_reset_pw.xml file to directory where hponcfg.exe file exists.


Open the command prompt (cmd)


Change the directory to where hponcfg.exe file exist (Usually c:\ProgramFiles\HP\hponcfg directory )


Type HPONCFG.exe /f Administrator_reset_pw.xml /l log.txt > output.txt (Press Enter)


After executing the command above, look inside the output.txt and log.txt files for error messages. If you have no error message(s). Your ILO password should be changed.


If you get "ERROR :firmware flash is in progress.Please wait for a while." you should use the newer version of hponcfg.exe file.


You can download the file from the links above.


For Windows 2003/2008 x86


For Windows 2003/2008 x64


Read more...

MSA 1000 ,1500 Controller and Disk Status Check

      You can check your Controller , Physical and Logical Drives status by using "Array Configuration Utility CLI"

Open Array Configuration Utility by using programs menu.



In the Command Prompt type

ctrl all show config detail (Press Enter)

By using this command you can view ;

  • Logical & Physical Drives status
  • RAID Status
  • Stripe Size
  • Serial & Model Number of Controllers and Disks
  • Physical Disk Transfer Speed
  • Physical Transfer Mode
  • Firmware Revision 
  • Interface Type ( SCSI, SAS,...)
  • Disk Rotational Speed...etc

Read more...

Monday, February 16, 2009

SQL Server 2005 Disk Bottleneck & Low CPU Utilization

If CPU utilization is low on your SQL server but response time or run time is high, you might have a disk bottleneck. The Disk Perfmon counters might provide the insight needed for
tuning most of the sequential I/O workloads.
However, in the OLTP workload, the disk load of the log and checkpoint
processes are adjusted by SQL Server. This means the log and checkpoint
processes are invisible to Perfmon.
When writing to the log, the disk queue length is kept at 1. Likewise, the
checkpoint is controlled so that it does not swamp the disk and severely reduce
throughput.


In this case, you can use the query below to capture reads, writes,
and I/O stalls by the database file.

select m.name, v.*, m.physical_name
from sys.dm_io_virtual_file_stats (null, null) v
,sys.master_files m
where v.database_id = m.database_id
and v.file_id = m.file_id



Using this information, you can determine reads/sec, writes/sec, read and write
block sizes, and average number of milliseconds in wait time (I/O stalls) for read
and write operations. If the wait times are large, putting the files in faster disk
arrays can improve database performance.
Read more...

Cisco Servers are coming in the Near Future...

http://blogs.techrepublic.com.com/hiner/?p=898&tag=nl.e101
Read more...

Friday, February 13, 2009

Remove a driver for a hardware device on Windows 2008 Core

To get the list of installed drivers type the comman below at the command prompt.
sc query type= driver

2. At the command prompt, type the command below to remove driver
sc delete  <Servicename>. 
Read more...

Adding Hardware Driver to Windows 2008 Core Edition

Steps for installing Hardware Driver on Windows 2008 Core

1 If the driver for your new hardware is included in Windows Server 2008, Plug
and Play will start and install the driver automaticly.
· If the driver for the hardware is not included in Windows 2008 core
2. Copy the driver files to a temporary folder on the server running a Server Core
installation.
3.On the command prompt, open the folder where the driver files are located and tye the command below

pnputil -i -a driverinf //driverinf is the name of your ".inf" file

4. If prompted, restart the computer.
Read more...

Comparision table MSA 1500 vs IBM DS3200 and DS3400


Read more...

Comparision table MSA 1000 vs IBM DS3200 and DS3400


Read more...

Number of tasks queued in SQL Server that can be run

The following query shows the number of tasks queued in SQL Server that can be run:

select avg(runnable_tasks_count)   from sys.dm_os_schedulers   where status = 'VISIBLE ONLINE'

If SQL Server frequently has a non-zero number of runnable tasks, then adding additional processors will likely result in more throughput.



Read more...

SQL Server I/O statistics by table/index

select object_name(i.object_id) as table_name       ,i.name as index_name, s.*   from sys.dm_db_index_operational_stats(null, null, null, null) s       ,sys.indexes i  where i.object_id = s.object_id    and i.index_id  = s.index_id    and objectproperty(s.object_id,'IsUserTable') = 1  order by database_id, table_name, index_name, partition_number


Read more...

Configuring Backup Line using "ip route" command on Cisco Routers

Assume that your router have two chance to go to one of your office. You can determine backup line to your router by assigning metric value 255  to your routing command.

Example Command
ip route 30.0.0.0 255.255.255.0 192.168.102.1 255  (This Route is backup line)


Read more...

Rebuild Windows 2000 and Windows 2003 Terminal Services Licensing database

1)Stop "Terminal services licensing" service from services console
2)Rename the Winnt\System32\lserver folder to lserver1 (or sth else)
3)Create new folder named LServer in Winnt\System32\ directory
4)Start the "Terminal services licensing" service from services console


Read more...

Leased Line Configuration on Cisco Routers

interface Serial0/0

 ip address 15.0.0.1 255.255.255.252

 no ip mroute-cache

 autodetect encapsulation ppp

 no fair-queue

 


Read more...

Frame Relay Configuration on Cisco Routers (Cisco 2801 , Cisco 1751)

Cisco 2801 Configuration

interface Serial0/3/0
 no ip address
 encapsulation frame-relay IETF
!
interface Serial0/3/0.1 point-to-point
 ip address 40.0.0.1 255.255.255.252
 frame-relay interface-dlci 100    //You should get DLCI number from your service provider.

Cisco 1751 Configuration

interface Serial0
 no ip address
 encapsulation frame-relay IETF
!
interface Serial0.1 point-to-point
 ip address 40.0.0.2 255.255.255.252
 no arp frame-relay
 frame-relay interface-dlci 100




Read more...

How can you prevent HP SIM to discover Orphan system in Windows environment...

Delete The Registry Key,

HKLM\SOFTWARE\COMPAQ\CIMAgent\GUID
Read more...

Unable to PXE boot into HP Rapid Deployment Pack

If your Proliant server unable to PXE boot into HP RDP to deploy a new operating system...

Solution :

Reset the System Using RBSU advanced option . Erase NVRAM and Disk.
Read more...

Thursday, February 12, 2009

Blocking Log on to Computers when they are not connected to Domain.

When connected to the domain, Windows OS is caching the domain credentials locally so that users can login to computers even when the domain isn't available.

To prevent this behavior you should modify value of the "cachedlogonscount" key to 0(zero)

cachedlogonscount key is located in the location below;

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
Read more...

How to Delete a Windows Service in Vista or XP


Instead of disabling a services, you can completely delete the services. This technique can be helpful if the software that you uninstalled, leaves an item in the service list.

You should be very carefull while deleting service , it is very hard to restore the service back. So carefully determine the service that you want to delete.

Deleting a service ;
Open Command Prompt (cmd)
Type:
sc delete ServiceName
If your service name has spaces in it, you should type its name in quotes like this:
Example:
sc delete "Virus Programme"
After completing this step , open Services management console again and you will see that the service is gone.

Read more...

Problem With Copying Large Files in Windows Vista over Network

If you have problems about copying large files over network, (network disconnection or router crashes ) then you can try out this solution to solve the problem.

Cause of this problem is auto-tuning options in Windows Vista . To disable autotuning features

Open Administrative Mode Command Prompt

Either type cmd into the start menu and use Ctrl+Shift+Enter or right-click the Command

Prompt shortcut and choose Run as Administrator.

netsh int tcp set global autotuninglevel=disabled

You should reboot your system after typing command. if your problem is not resolved you can turn on autotuning feature again.

netsh int tcp set global autotuninglevel=normal
Read more...

Wednesday, February 11, 2009

Blocking Instant Messengers on Cisco PIX / ASA

Blocking ASA
Read more...

ISA Server Error Code 502

If you are using ISA 2006 and getting Error Code 502 try the solution below.


The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.
Technical Information (for support personnel)
Error Code: 502 Proxy Error.
The HTTP message includes an unsupported header or an unsupported combination of headers. (12156)

The event that can cause to this problem is HTTP header that begins with a space or with a TAB character space.

To solve this issue.

Change the registry key stated below value to 1

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\Web FiltersValue DROP_CONTINUATION_LINES
Read more...

Monday, February 9, 2009

2 Mbit E1 line at Center Office, Leased Line and Frame Relay Line at Branch office configuration on Cisco Router 2610

We have a 2 Mbit E1 line on Center Office(Cisco 2610) and on the branch offices we have Leased Lines and Frame Relay line at (Cisco 805 , Cisco 800 ,Cisco 1000) various speeds.


Our Topology as follows ,









Timeslots number :16
Timeslots speed : 64 Kbps

And the configuration is below,







Read more...

Securing Cisco routers against flaw attack (IOS 12.3 ,12.4)

To find out which version of IOS, you have on your Cisco Router, type the command below in privilege exec mode.

show version

Routers that have the Cisco Unified Communications Manager and voice services enabled can affected by flaw attack. If you are unsure whether your routers have voice services (the SIP protocol) enabled, you should check.


Execute following three commands to see if your router is listening for incoming SIP requests:

show ip sockets

show udp

show tcp brief all






You should look for inbound openings (listeners) for the following protocols and port numbers: TCP 5060, 5061, 1720, 11720 and UDP 5060, 5061, 2427, 2517, 16384 - 32767.






Notice the port number 5060 exists in both cases.


Protecting your Cisco routers from flaw attack.

1) Check to see whether there is an upgrade to the IOS software that contains the bug fix for this vulnerability. It may be hard to upgrade your routers, but this is a good solution. What you should do immediately is either disable the SIP service if it is not needed or perform traffic mitigation to ensure that only legitimate traffic can be sent to and from the affected Cisco routers.


Disable SIP protocol


Router(config)# sip-ua
Router(config-sip-ua)# no transport udp
Router(config-sip-ua)# no transport tcp
Router(config-sip-ua)# end


These commands would disable the SIP protocol and protect you from this vulnerability.
Lastly, if the SIP protocol is needed on your router and if there is no IOS upgrade available, you should go through traffic filtering by authorizing only valid traffic to your affected Cisco IOS devices by creating an access list (ACL) that permits all SIP traffic from known SIP devices on your LAN and denies SIP traffic from all other unknown hosts.
Read more...

Friday, February 6, 2009

How to Extend 4095 MB page file limit on Windows Server 2003 x86 Servers

To extend 4095 MB page file limit in one disk. Follow the steps below.

1) On the drive or volume that you want to store the paging files, create folders for the number of paging files that you want to create on the drive or volume. For example, C:\Pagefile1, C:\Pagefile2, and C:\Pagefile3.

2) Open registry editor.

3) Find HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\SessionManager\MemoryManagement
Pagingfiles key and remove the values exist and add the values below.
c:\pagefile1\pagefile.sys 3000 4000
c:\pagefile2\pagefile.sys 3000 4000
c:\pagefile3\Pagefile.sys 3000 4000

4) Click OK and restart your server.
Read more...

Client using Outlook 2007, Exchange 2007 Certificate Error on Cisco Router based network

If the Outlook 2007 clients and Exchange Server in your organisation are on a different subnets and router connecting these subnet is listening port 443 , the auto discover mode of Outlook 2007 and Exchange 2007 may fail because of DNS name resolution problem. Auto discover service allows your Outlook 2007 clients to retrieve the URLs that it needs to gain access to the new web services offered by Exchange 2007.
Cause of this failure is certification mismatch that outlook use to create secure connection channel between client and server.
Use "no ip http secure-server" command on Cisco router, to prevent router from listening https port.
Read more...

Thursday, February 5, 2009

0X8004010F Error

If Client using Outlook 2007 and the mail server is Exchange 2007 an your client is getting error below,

Not downloading offline address book files. A server (URL) could not be located. 0X8004010F hatası ile kaşılaşıyorsanız ;

Solution Offer 1 )

Do not use Cached Exchange Mode in outlook accounts.

Solution Offer 2)

Problem is caused by your internet explorer proxy settings. Be sure that "Bypass proxy server for local address" is checked in your proxy settings.



Read more...

Exchange 2007 Hubtransport role installation error(Event id:1002 "Exchange Server component Hub Transport Role failed"))

Exchange 2007 Hubtransport role installation error

Event Source: MSExchangeSetup
Event ID: 1002
Task Category: Microsoft Exchange Setup
Level: Error
Keywords: Classic
Description: Exchange Server component Hub Transport Role failed.
Error: Error: An error occurred. error code was 2147504141 message was The property cannot be found in the cache.."

This error is caused by IPv6 settings on your Exchange server. IPv6 should be disabled.



Disabling IPv6

1) Open Registry Editor (Regedit)
2) Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters subkey.
3) In the details pane create new DWORD( 32 bit) value. Name it as "DisabledComponents"
4) And modify its value to 0xffffffff Hexadecimal.

This process will disable all IPv6 components except IPv6 loopback interface.


Read more...

Exchange 2007 is working on Windows 2008 server and you can not send emails to some domains...

Try telnet to smtp port of mail server that you can not send emails. Probably you will see a blank black screen. Type "ehlo domain.com" on black screen and press enter. Now you should be able to see SMTP banner.

If you try telnet to this mail server on smtp port you will see SMTP banner without typing any other command.

Problem is caused by "TCP autotuning" feature that is not supported by routers. We should disable autotuning feature to solve this problem.



Type the command below in the command prompt and press Enter

netsh interface tcp set global autotuninglevel=disabled

After doing this process restart the email server and try sending email to releated domain.


Read more...

If you are facing with "STATUS_INVALID_PARAM" error on Windows 2008 or Windows Vista while you are using "Send NTLMv2" authentication...

I suggest you tu back up your regsitry before doing above process.


1) Open Registry Editor(Regedit)
2) Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0 subkey
3) Create new Dword(32-bit) value and name it as AllowLegacySrvCall
4) Modify new Dword value to 1.
5) Restart your Server or PC.
Read more...

Removing Administrative Shares in Windows 2008

After installation of Windows 2008 , it automaticly creates administrative shares that are aimed to used by administrator user groups, services and programs.

ADMIN$: This administrative share is used for remote administration purpose.
IPC$: This administrative share is used for communications between programs and sharing named pipes. It can not be deleted
NETLOGON: This administrative share is used by DCs
SYSVOL: This administrative share is used by DCs.
PRINT$: This administrative share is used for remote administration of prniters
FAX$: This administrative share is used for fax clients while sending faxes.

To remove administrative share follow the procedures aboce.

1) Open registry editor (Regedit)
2)Find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
\LanmanServer\ParametersNote subkey.
3) Find or create AutoShareServer (DWORD 32 bit)) key and modify its value to 0
4)Restart your server.

Not: Bu ayar IPC$ paylaşımını veya diğer manuel olarak yarattığınız paylaşımları etkilemeyecektir.
Read more...

If you are expericing network connectivity fails when you try to use Windows Vista behind a firewall.

If you are facing with slow responds and crashing while your using programs below.

Microsoft Outlook
Windows Mail
Web browser
Remote Desktop Connection (RDC)

I suggest you yo try this steps.

1) Open Command Prompt. (Cmd)
2) Type netsh interface tcp set global autotuninglevel=disabled ( Enter)
3) Restart your computer.
Read more...

SQL query that shows detailed sizes of tables in SQL database..


SQL query that shows detailed sizes of tables in SQL database..

select
so.id as [OBJECT_ID],
so.name as [OBJECT_NAME],
coalesce(j_rows.rows,0) as [ROWCOUNT],
coalesce(j_ru.sum_reserved,0) * cast(m.low as dec) / 1024 as [RESERVED (KB)],
d.data * cast(m.low as dec) / 1024 as [DATA (KB)],
(coalesce(j_ru.sum_used,0) - d.data) * cast(m.low as dec) / 1024 as [INDEX (KB)],
(coalesce(j_ru.sum_reserved,0) - coalesce(j_ru.sum_used,0)) * cast(m.low as dec) / 1024 as [UNUSED (KB)]
from
sysobjects so
join master.dbo.spt_values m
on m.number = 1 and m.type = 'E'
-- rows
left join sysindexes j_rows
on j_rows.indid < 2 and j_rows.id = so.id
-- reserved: sum(reserved) where indid in (0, 1, 255)
-- index: sum(used) where indid in (0, 1, 255) - data
-- unused: sum(reserved) - sum(used) where indid in (0, 1, 255)

left join

(
select
id
, sum(reserved) as sum_reserved
, sum(used) as sum_used
from
sysindexes
where
indid in (0, 1, 255)
group by
id
) j_ru
on j_ru.id = so.id
-- data: sum(dpages) where indid < 2
-- + sum(used) where indid = 255 (text)
left join
(
select
j_dpages.id
, coalesce(j_dpages._sum,0) +
coalesce(j_used._sum,0) [data]
from
(
select
id
, sum(dpages) [_sum]
from
sysindexes
where
indid < 2
group by

id

) j_dpages

left join

(
select
id
, sum(used) [_sum]
from
sysindexes
where

indid = 255
group by
id
) j_used
on j_used.id = j_dpages.id
) d

on d.id = so.id
where
objectproperty(so.id, N'IsUserTable') = 1
order by

[DATA (KB)] DESC, [ROWCOUNT] ASC
Read more...

Monday, February 2, 2009

Removing domains or child domains those are not hosting by functional Domain Controllers in your AD structure + Error 0x2162


Picture2

Picture1
Removing domains or child domains those are not hosting by functional Domain Controllers in your AD structure.
Follow these steps on server that is holding Domain Namig Master FSMO role.
run -- cmd

ntdsutil (Enter)

metadata cleanup (Enter)

connections (Enter)

connect to server servername (Enter) "Servername is name of server that is holding Domain Naming Master FSMO role.

quit (Enter)

select operation target (Enter)
list domains (Enter)
select domain numara (Enter) "Choose the domain number that you want to remove"

remove selected domain (Enter)
After applying last step press yes in warning and your domain will be removed.

If you are facing with " error 0x2162(The requested domain could not be deleted because there exist domain controllers that still host this domain.)" error in the last step you should remove unfunctional domain controllers manually.

Open Active Directory Sites and Services Console.
Expand unfunctional DC(Picture1).Right Click to that unfunctional DC NTDS settings and click Delete. In the warning screen select the third option(picture2) and click Delete
and lastly right click the unfuncyional server name and choose Delete.
Repeat the last step in ntdsutil again "remove selected domain" and your unfunctional domain will be removed.

Read more...

File Replication Service JRNL_WRAP_ERROR on SYSVOL

If yuo are facing with Jrnl_wrap_error while you are checking FRS replica sets by using "ntfrsutl sets dc_name" command.

You should follow these steps below to remove error.


1) Stop FRS service in related DC.
2) By using regedit find HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\NtFrs\Parameters\Backup/Restore\Process at Startup subkeyand modify BurFlags key value to Hex:D2

3) Close Regedit.

4) Start FRS service.

After FRS service is restarted.

BurFlags key value will be 0(zero) again. and FRS database will be recreated automaticly.

If you continue to get the same error after doing these steps. Follow these steps again but this time set BurFlags key value to D4

I hope it will work for you...


Read more...

Viewing FSMO role holders in AD structure...


Method 1)

Viewing FSMO role holders by using ntdsutil command tool.

run--cmd--ntdsutil
ntdsutil: domain management
domain management: connection
connections: connect to server svdc
Binding to svdc ...
Connected to svdc using credentials of locally logged on user.
server connections: quit
domain management: select operation target
select operation target: list roles for connected server
Server "svdc" knows about 5 roles

Schema - CN=NTDS Settings,CN=SVDC,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=durak,DC=com,DC=tr

Domain - CN=NTDS Settings,CN=SVDC,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=durak,DC=com,DC=tr

PDC - CN=NTDS Settings,CN=SVDC,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=durak,DC=com,DC=tr

RID - CN=NTDS Settings,CN=SVDC,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=durak,DC=com,DC=tr

Infrastructure - CN=NTDS Settings,CN=SVDC,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=durak,DC=com,DC=tr
select operation target:


Method 2)

Viewing FSMO role holders By using dcdiag tool that you can find in Win2k support tools

cmd
dcdiag /test:Knowsofroleholders /v
Read more...
 
span.fullpost {display:none;}